Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: PimpYourKiT. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

zafirab19

Anfänger

  • »zafirab19« ist der Autor dieses Themas

Beiträge: 7

PHPKIT Version: PHPKIT 1.6.6

  • Nachricht senden

1

Sonntag, 22. März 2015, 16:39

Umlaute werden als Fragezeichen dargestellt

Nabend,

Bei ein paar Bereichen meiner Seite Zello - Der Virtuelle CB-Funk werden die Umlaute als Fragezeichen dargestellt, was kann man da machen.

bitte um hilfe.

In moment sind die Dokumente als UTF-8 gespeichert wo das Problem auftritt, was das Problem zwar löst, aber nicht so wie es soll, den die Codierung verursacht über und scheinbar unter dem Dokument zeilenumbrüche, warum auch immer.

Mache dein Mobielgerät oder PC, zu einem Funkgerät.

Igelmonster

Verifiziertes Mitglied

  • »Igelmonster« ist männlich
  • »Igelmonster« ist ein verifizierter Benutzer

Beiträge: 172

Wohnort: Hadamar

Beruf: Stromer

PHPKIT Version: PHPKIT 1.6.8 by PYK

Danksagungen: 20 / 35

  • Nachricht senden

2

Sonntag, 22. März 2015, 19:11

Hallo, hast du alle Sammelpatches für die 1.6.6 installiert und ist die Datenbank richtig eingestellt? Seit wann tritt das Problem auf?

LG
Eine relativ gute Rechtschreibung ist ein Zeichen von Respekt.
Zeichensetzung kann Leben retten: Komm wir essen Opa...

reddevil82

PHPKIT Oldie

  • »reddevil82« ist männlich
  • »reddevil82« ist ein verifizierter Benutzer

Beiträge: 3 204

Wohnort: Spiesen-Elversberg

Beruf: Einzelhandelskaufmann

PHPKIT Version: Kein PHPKIT

Danksagungen: 1028 / 371

  • Nachricht senden

3

Sonntag, 22. März 2015, 20:23

Und vorallem in welchen Bereichen? Kommen die Umlaute aus der DB? Oder sind die via HTML bzw. PHP?

Bitte genauere Information damit wir helfen können.
Auch mal den Bedanken Button nutzen tut nicht weh und der Ersteller freut sich umso mehr.

Zitat von »Friedrich Nietzsche«

Der, welcher etwas Großes schenkt, findet keine Dankbarkeit, denn der Beschenkte hat schon durch das Annehmen zu viel Last.

zafirab19

Anfänger

  • »zafirab19« ist der Autor dieses Themas

Beiträge: 7

PHPKIT Version: PHPKIT 1.6.6

  • Nachricht senden

4

Montag, 23. März 2015, 07:53

Ähm nene aus der DB denke ich nicht,den das Problem tretet bei den htm Dokumenten auf die ich selber geschrieben habe.

die DB müsste auch auf UTF-8 eingestellt sein.

Sammelpatch, bin nicht sicher, kann ich ja mal einspielen.

Die bereiche:
Auf der Startseite ganz unten die drei Kästchen, das wo Zello steht.
Und der Bereich Was ist Zello?, zu finden Links in der Navigation bei Über Zello.

Beides htm Dokumente ohne DB.

So habe den Sammelpatch SP9 und auch das Mysqli eingefügt, behebt das Problem jedoch leider nicht.

Mache dein Mobielgerät oder PC, zu einem Funkgerät.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »zafirab19« (23. März 2015, 08:19)


Icejack

Verifiziertes Mitglied

  • »Icejack« ist männlich
  • »Icejack« ist ein verifizierter Benutzer

Beiträge: 440

Wohnort: Moers

Beruf: Beamter

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 57 / 80

  • Nachricht senden

5

Montag, 23. März 2015, 10:29

Hast du die html Dokumente selbst erstellt?

Zitat

Courage heißt, alles zu riskieren, alles zu setzen und vielleicht alles verlieren.

zafirab19

Anfänger

  • »zafirab19« ist der Autor dieses Themas

Beiträge: 7

PHPKIT Version: PHPKIT 1.6.6

  • Nachricht senden

6

Montag, 23. März 2015, 11:50

Ja

Mache dein Mobielgerät oder PC, zu einem Funkgerät.

Schaddi

Anfänger

  • »Schaddi« ist männlich

Beiträge: 32

Wohnort: Bremen

PHPKIT Version: PHPKIT 1.6.5

Danksagungen: 8 / 19

  • Nachricht senden

7

Montag, 23. März 2015, 12:11

Mich selbst irretiert dieses html

HTML

1
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1">

eigentlich sollte das

HTML

1
<meta http-equiv="content-type" content="text/html; charset=utf-8">
heißen.
Schau doch mal in der site.html nach.

Angabe der Zeichencodierung in HTML

knuddi

Verifiziertes Mitglied

  • »knuddi« ist männlich
  • »knuddi« ist ein verifizierter Benutzer

Beiträge: 942

Wohnort: Finsterwalde

Beruf: Bürokraft

PHPKIT Version: PHPKIT 1.6.8 by PYK

Danksagungen: 279 / 416

  • Nachricht senden

8

Montag, 23. März 2015, 12:31

Genau, aber eigentlich sollte diese Zeile schon in die site.htm vom style rein und bei den Umlauten deiner htm Dokumente unbedingt diese Schreibweisen verwenden! HTML schreibweise für ä,ö,ü,ß › Daniel Hüsken
Mach auch du mit bei AC-Town Virtual Town ~~AC-Town Virtual Town~~

zafirab19

Anfänger

  • »zafirab19« ist der Autor dieses Themas

Beiträge: 7

PHPKIT Version: PHPKIT 1.6.6

  • Nachricht senden

9

Montag, 23. März 2015, 13:02

Warum muss man diese Umlaute dinger nutzen, ging vorher doch auch ohne.

und den code:
<meta http-equiv="content-type" content="text/html; charset=utf-8">

in der site habe ich auch schon ausprobiert, reagiert nicht

Mache dein Mobielgerät oder PC, zu einem Funkgerät.

knuddi

Verifiziertes Mitglied

  • »knuddi« ist männlich
  • »knuddi« ist ein verifizierter Benutzer

Beiträge: 942

Wohnort: Finsterwalde

Beruf: Bürokraft

PHPKIT Version: PHPKIT 1.6.8 by PYK

Danksagungen: 279 / 416

  • Nachricht senden

10

Montag, 23. März 2015, 18:55

Man muss die wegen utf 8 nutzen, damit es auch valide und so ist, sonst wie du ja siehst, wird das mit so fragezeichen und kästchen angezeigt.
Mach auch du mit bei AC-Town Virtual Town ~~AC-Town Virtual Town~~

zafirab19

Anfänger

  • »zafirab19« ist der Autor dieses Themas

Beiträge: 7

PHPKIT Version: PHPKIT 1.6.6

  • Nachricht senden

11

Montag, 23. März 2015, 21:55

Problem gelöst,
ein großen danke an Sascha.

Mache dein Mobielgerät oder PC, zu einem Funkgerät.

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

12

Montag, 23. März 2015, 21:59

Problem war das die DB auf latain1 stand anstatt auf utf-8

gern geschehe ich hoffe du hast was lernen können dabei ^^

:close:

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

Es haben sich bereits 3 registrierte Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

knuddi (23. März 2015, 22:56), reddevil82 (24. März 2015, 15:03), Igelmonster (24. März 2015, 22:06)

Social Bookmarks