Sie sind nicht angemeldet.

Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

1

Donnerstag, 11. Oktober 2012, 08:53

Usermap für 1.6.5

Hallo,

wir nutzen zwar phpkit 1.6.6 aber die Addons vom 1.6.5 sollen alle kompatibel sein. (Wir haben auch ein paar Addons laufen, die für 1.6.5 geschrieben sind.)

Die Usermap will aber partout nicht laufen. Ich bekomme schon bei der Installation folgenden Fehler:

Quellcode

1
2
Generating config-file: GD2-Imagedateien erstellen: OK OK OK OK OK OK usermap/imagesOK 
OK Tables erstellen: OK Fehler OK Fehler OK Fehler 


Ich tippe da auf ein Problem mit dem mysql-Aufruf. Auf dem Server ist php 5.x, mysql 5.x und die neueste Version des Apache installiert. Wir wollten auch die coppermine-galery installieren, aber auch dies schlug fehl. Ein Bekannter, der sich das kurz anschaute meinte, es hat was mit einem veralteten sql-Befehl zu tun.

Kann mir jemand bei dem Problem helfen?

Gruß

Ulf
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Perry_Rhodan« (13. Oktober 2012, 14:45)


Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

2

Donnerstag, 11. Oktober 2012, 10:18

Moin,

ich habe eben die usermap testweise bei mir auf testkit installiert und funktioniert einwandfrei. Sowie auch das Setup siehe Screens.

  1. Zwei Datein pkinc/lang/de/admin.php & pkinc/etc/sql.php bearbeiten und hochladen.
  2. Ordner usermap/images die CHMOD Rechte 777 vergegeben.
  3. Zwei Ordner pkinc & usermap hochladen.
  4. Adminbereich das geforderte Profilfeld erstellen.
  5. Im Profil die PLZ hinterlegen.
  6. Die setup.php aufgerufen.
  7. Die installations routine durchführen.
  8. Die usermap aufgerufen.
Und konnte keine Fehler feststellen.

Stelle sicher das alle rechte gesetzt wurden.

MfG Sascha
»Sascha« hat folgende Bilder angehängt:
  • Setup.jpg
  • Install.jpg
  • Profilfeld.jpg
  • Adminbereich.jpg
  • Usermap.jpg

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

3

Donnerstag, 11. Oktober 2012, 11:06

Hallo Sascha,

die geforderten Einstellungen wurden gemacht, trotzdem komme ich nicht über das anlegen der Tabellen hinaus. Die Fehlermeldung bleibt.

Folgende Tabellen sind in der Datenbank angelegt, fehlt denn dort eine?



Es ist ein Problem beim Anlegen der Tabellen, soweit glaube ich es zu erkennen.

Gruß

Ulf
»Perry_Rhodan« hat folgendes Bild angehängt:
  • tabellen.jpg
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

4

Donnerstag, 11. Oktober 2012, 11:45

Kannst du in TS kommen ?

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

Perry_Rhodan (11. Oktober 2012, 13:51)

Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

5

Donnerstag, 11. Oktober 2012, 12:18

Würde ich ja gerne, nur kommt nach dem Klick auf "Verbindung herstellen" nur "Diese Website kann nicht angezeigt werden.

Brauche ich noch irgendein Progi um TS zu nutzen? Habe noch nie TS benutzt.

Gruß

Ulf
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

6

Donnerstag, 11. Oktober 2012, 12:20

ich versuche es
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

7

Donnerstag, 11. Oktober 2012, 12:24

Bin da, glaub ich ;)



Oder auch nicht, starte mal mein pc neu
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Perry_Rhodan« (11. Oktober 2012, 12:31)


Perry_Rhodan

Anfänger

  • »Perry_Rhodan« ist männlich
  • »Perry_Rhodan« ist der Autor dieses Themas

Beiträge: 8

Wohnort: Berlin

Beruf: CIO/CTO

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 0 / 1

  • Nachricht senden

8

Donnerstag, 11. Oktober 2012, 13:51

Dank Sascha hat es nun geklappt.

Wie vermutet, hat er bei der Installation einige Datenbanktabellen (eigentlich bis auf 1 alle) nicht angelegt.

Ob es nun an der neusten Version von mysql oder an den Tabellenpräfixen liegt, konnten wir nicht ganz klären.

Eine manuelle Anlage der fehlenden Tabellen brachte zumindest den gewünschten Erfolg.

Danke Sascha.

Gruß

Ulf
Theorie ist, wenn man alles weiß, aber nichts funktioniert.
Praxis ist, wenn alles funktioniert aber keiner weiß warum.
Hier ist Theorie und Praxis vereint! Nichts funktioniert und keiner weiß warum !!!

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

9

Donnerstag, 11. Oktober 2012, 14:21

Kein Problem gern geschehen.

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

reddevil82

PHPKIT Oldie

  • »reddevil82« ist männlich
  • »reddevil82« ist ein verifizierter Benutzer

Beiträge: 3 204

Wohnort: Spiesen-Elversberg

Beruf: Einzelhandelskaufmann

PHPKIT Version: Kein PHPKIT

Danksagungen: 1028 / 371

  • Nachricht senden

10

Donnerstag, 11. Oktober 2012, 16:39

Wurde das vor der Installation beachtet?

Quellcode

1
2
3
4
5
6
7
8
9
10
----------->
Editiere die pkinc/etc/sql.php
----------->
Füge ganz unten VOR ?> das ein:
/**************************************** USERMAP Anfang ****************************************/
define('pkSQLTAB_UM_CITIES',pkSQLPREFIX.'_usermap_cities');
define('pkSQLTAB_UM_COUNTRIES',pkSQLPREFIX.'_usermap_countries');
define('pkSQLTAB_UM_DATA',pkSQLPREFIX.'_usermap_data');
define('pkSQLTAB_UM_CONFIG',pkSQLPREFIX.'_usermap_config');
/**************************************** USERMAP Ende   


Thema wurde editiert

Hat sich erledigt habe den fehler soeben feststellen können. Und zwar fehlt komischerweise ein Ordner im Download setupdir. Deshalb könnten die Tabellen nicht angelegt werden.

@Sascha: kannste da nochmal bei dir guggen ob der bei dir vorhanden ist?
Auch mal den Bedanken Button nutzen tut nicht weh und der Ersteller freut sich umso mehr.

Zitat von »Friedrich Nietzsche«

Der, welcher etwas Großes schenkt, findet keine Dankbarkeit, denn der Beschenkte hat schon durch das Annehmen zu viel Last.

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

11

Donnerstag, 11. Oktober 2012, 16:41

Ja bei mir existiert der.

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

Social Bookmarks