Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: PimpYourKiT. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

neumicha

Schüler

  • »neumicha« ist der Autor dieses Themas

Beiträge: 60

Danksagungen: 8 / 2

  • Nachricht senden

1

Sonntag, 16. Dezember 2012, 18:35

Problem mit Geschenkeaddon und Googie Spell

Hallo,

ich habe mal 2 Fragen.

Wenn ich die Seite aufrufe, wo ich ein geschenk auswählen kann, erhalte ich immer in der Statuszeile unten Links

ein Gelbes Warndreieck mit folgender Fehlermeldung:

Hier klicken für weitere Informationen


Javascript-Quelltext

1
2
Details zum Fehler auf der Webseite Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)Zeitstempel: Sun, 16 Dec 2012 17:03:46 UTC Meldung: 'GoogieSpell' ist undefiniertZeile: 404Zeichen: 6Code: 0 
URI: http://www.Meine-Page.de/include.php?path=geschenke&mode=make&id=5




Ich habe das neue jquery-1.8.3.min.js hochgeladen,

in den Hauptordner wo die include.php ist und in den Ordner fx/autoComplete

dort ist aber auch noch die Datei: jquery-1.2.1.pack.js

Ehrlich gesagt, weiß ich nun nicht wo die jquery-1.83.min.js hin muss.

Kann man dann die jquery-1.2.1.pack.js löschen?

Bitte schreibt mir, wie genau ich da was machen muss.

Übrigens, den js Fehler habe ich auch immer bei anderen JS Angelegenheiten und das nervt.

Zum Geschenkaddon:

Wenn ich die Seite bei einem User aufrufe um diesem ein Geschenk zu machen,

also wo ich ein Geschenk auswählen kann für den User werden mir in einer Reihe 6 Geschenke angezeigt.

Jetzt passiert mir, dass jedesmal die rechten Navboxen halb abgeschnitten werden. Was ätzend ausschaut.

Nun habe ich in den php Seiten rumgesucht, ob es irgendwo eine Einstellung gibt, dass in einer Reihe nur noch

5 oder 4 Geschenke angezeigt werden. Ich dachte, ich wäre fündig geworden in der

pkinc/public/geschenke/includes/userinfo.inc.php

Dort gibt es in der Zeile 22 diesen Code:

PHP-Quelltext

1
define('SPLIT',6); //--> Anzahl der Spalten pro <tr></tr>


Ich habe die Zahl mal von 6 auf 5 gesetzt, in der Hoffnung, dass die Geschenke dann nicht mehr als 6 in einer Reihe sondern nur noch 5 angezeigt werden, leider ohne Erfolg.

Gibt es dafür überhaupt eine Einstellung? Falls ja, bitte wo?

Thema wurde editiert

Das mit der Geschenkeanzahl in der Reihe hat sich erledigt!

ich habe in der pkinc/public/geschenke/make.php

in den Zeilen 97 und 103 die Einstellungen gefunden und von 6 auf 5 geändert.

Nun werden in einer Reihe 5 Geschenke angezeigt und die rechten Navboxen sind auch wieder komplett da.

Bleibt nur noch die JS Geschichte.



Im Voraus vielen Dank für eure Hilfe, mit der bitte was das JS angeht nicht auf andere Postings verweisen, denn da habe ich nicht durchgeblickt.

MfG

neumicha

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »neumicha« (16. Dezember 2012, 18:47)


reddevil82

PHPKIT Oldie

  • »reddevil82« ist männlich
  • »reddevil82« ist ein verifizierter Benutzer

Beiträge: 3 204

Wohnort: Spiesen-Elversberg

Beruf: Einzelhandelskaufmann

PHPKIT Version: Kein PHPKIT

Danksagungen: 1028 / 371

  • Nachricht senden

2

Sonntag, 16. Dezember 2012, 18:49

Was das JQuery angeht ist es dir überlassen wohin du es schiebst wichtig ist das nachher die Verlinkung ( praktisch die URL zur Datei ) richtig in den eigenen Metaangaben eingetragen ist.

Ich empfehle dir aber um die Übersicht zu erhalten in den fx Ordner. Wenn du mehrere JQuery Dateien eingebunden hast kann es u.a. passieren das sich die "beissen". Daher empfehle ich dir was JQuery angeht immer die aktuellste automatisch per Google laden zu lassen dann haste damit keinen kummer mehr. Wie das geht siehste hier:

Beide Versionen JQuery Core richtig einbinden
( ja ist zwar ein Link aber dort isses Schritt für Schritt erklärt )

So nun zum Geschenke Addon:

suche in der make.php

PHP-Quelltext

1
            if($count == 6)

PHP-Quelltext

1
$cs $count;

und passe das an.

PS: Bitte es nächste mal 2 Themen eröffnen dann blickt man später bei mehreren Einträgen besser durch ob es nun um Geschenke oder JQuery geht.
Auch mal den Bedanken Button nutzen tut nicht weh und der Ersteller freut sich umso mehr.

Zitat von »Friedrich Nietzsche«

Der, welcher etwas Großes schenkt, findet keine Dankbarkeit, denn der Beschenkte hat schon durch das Annehmen zu viel Last.

neumicha

Schüler

  • »neumicha« ist der Autor dieses Themas

Beiträge: 60

Danksagungen: 8 / 2

  • Nachricht senden

3

Montag, 17. Dezember 2012, 09:42

Hallo reddevil82,

das habe ich ja selbst gefunden mit dem Einstellen von den Geschenken.

Dennoch danke.

So nun aber zu dem script, dass ich in der admintpl/site.htm stehen habe

HTML

1
<script type="text/javascript" src="http://www.meine-page.de/fx/autoComplete/jquery-1.8.3.min.js"></script> 


Zudem steht in der site.htm noch ein script code:


Wenn ich in der fx/ nachsehe, ist der Ordner ASCEUploader gar nicht vorhanden.

Das ASCE ist aber richtig installiert und funktionier auch einwandfrei.


Hier klicken für weitere Informationen


HTML

1
2
3
4
5
6
7
8
9
<!-- ASCE ANFANG --> 
<link href="fx/ASCEUploader/default.css" rel="stylesheet" type="text/css" /> 
<link href="fx/ASCEUploader/uploadify.css" rel="stylesheet" type="text/css" /> 
<script type="text/javascript" src="fx/ASCEUploader/jquery-1.7.2.js"></script> 
<script type="text/javascript" src="fx/ASCEUploader/swfobject.js"></script> 
<script type="text/javascript" src="fx/ASCEUploader/jquery.uploadify.v2.1.4.min.js"></script> 
<!-- ASCE ENDE --> 
$site_header_script 
$site_refresh




Ich habe beide Varianten eingebaut, der Fehler ist immer noch vorhanden.

Wie du vermutest, könnte es sein, dass sich eventuell was gegenseitig stört.

Hier mal alle JS, die ich unter fx/autoComplete habe.

autoComplete.js, jquery-1.2.1.pack.js, jquery-1.8.3.min.js

und hier alle JS Dateien in dem Ordner fx/

form.js, main.js, popup.js, pwd_strength.js

So, nun hoffe ich, dass irgenwas machbar ist.

Danke im Voraus.

mfg

neumicha

reddevil82

PHPKIT Oldie

  • »reddevil82« ist männlich
  • »reddevil82« ist ein verifizierter Benutzer

Beiträge: 3 204

Wohnort: Spiesen-Elversberg

Beruf: Einzelhandelskaufmann

PHPKIT Version: Kein PHPKIT

Danksagungen: 1028 / 371

  • Nachricht senden

4

Dienstag, 18. Dezember 2012, 11:10

Also im ASCE wird doch bereits ein jquery geladen. Dann lädst du weiterhin jquery-1.2.1.pack.js.

was autocomplete.js ist weiss ich nicht und kenne ich auch.

Im Prinzip reicht es das neueste JQuery nur 1x einzubinden das ist ja bereits per Asce geschehen indem fall entferne doch mal die anderen.

Weitere Fehlerquellen können auch sein wenn du jquery mit MooTools oder Prototype JS Frameworks nutzt. Was aber imho bei dir nicht der Fall ist.

Handelt es sich eigentlich bei den Fehlern um die Seite in deinem Profil? Weil da sehe ich gar kein JS im Quelltext!

Was das ASCE im fx angeht steht der sicher unter pk/fx. Den alles was unter dem Ordner pk steht ist für den ACP Bereich gedacht.
Auch mal den Bedanken Button nutzen tut nicht weh und der Ersteller freut sich umso mehr.

Zitat von »Friedrich Nietzsche«

Der, welcher etwas Großes schenkt, findet keine Dankbarkeit, denn der Beschenkte hat schon durch das Annehmen zu viel Last.

neumicha

Schüler

  • »neumicha« ist der Autor dieses Themas

Beiträge: 60

Danksagungen: 8 / 2

  • Nachricht senden

5

Dienstag, 18. Dezember 2012, 13:49

Hallo,

ok, danke, dann werd ich den ganzen Kram mal probieren und durchforsten

mfg



neumicha

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

6

Donnerstag, 16. Januar 2014, 14:59

Hey,

ich habe den Geschenkeviewer 1.6.5 gerade bei uns installiert und mir sind zwei Sachen aufgefallen als ich ein paar Geschenke verteilt habe. Die Smilies werden in den Kommentaren zu den Geschenken nicht angezeigt und Googie Spell funzt dort auch nicht.
LG, mono

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

7

Donnerstag, 16. Januar 2014, 15:12

der geschenke viewer wurde noch nicht für 166 angepasst und deshalb kann ich auch net sagen was da nicht stimmt oder geht.

ja ggogiespell bzw google hat da was geändert man muss den pfad zur prüfung ändern.
bitte nicht in einem thread mehrer probleme ansprechen.

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

mono (16. Januar 2014, 19:39)

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

8

Donnerstag, 16. Januar 2014, 19:39

Bis auf das mit den Smilies habe ich alles hinbekommen.

googie spell:

pkinc/publictpl/geschenke/add.htm

suche:

Quellcode

1
2
3
4
5
6
7
		<td width="70%" valign="top" class="right">
			<textarea id="pkBBArea" name="content" cols="40" rows="20" class="w90" onfocus="pkBBSelection(this);" onclick="pkBBSelection(this);" onchange="pkBBSelection(this);" ondblclick="pkBBSelection(this);">$geschenk_text</textarea>
				<script type="text/javascript">
					var googie1 = new GoogieSpell("fx/spellcheck/js/", "fx/spellcheck/sendReq.php?lang=");
					googie1.decorateTextarea("pkBBArea");
				</script>
		</td>


ersetze mit:

Quellcode

1
2
3
4
5
6
	  <td width="80%" valign="top" rowspan="2"><textarea id="pkBBArea" name="content" cols="60" rows="12" class="w90" onfocus="pkBBSelection(this);" onclick="pkBBSelection(this);" onchange="pkBBSelection(this);" ondblclick="pkBBSelection(this);">$geschenk_text</textarea>
		<script type="text/javascript">
		var googie1 = new GoogieSpell("fx/googiespell/", "http://orangoo.com/newnox?lang=");
			googie1.decorateTextarea("pkBBArea");
		</script>
		</td>


IURL Link in der Info IM:

pkinc/public/geschenke/make.php

suche:

Quellcode

1
Weitere Informationen zu $usersender Geschenk findest Du [IURL=?path=geschenke] hier[/IURL] !!";


und eersetze mit:

Quellcode

1
Weitere Informationen zu $usersender Geschenk findest Du [URL=?path=geschenke] hier[/URL] !!";
LG, mono

knuddi

Verifiziertes Mitglied

  • »knuddi« ist männlich
  • »knuddi« ist ein verifizierter Benutzer

Beiträge: 942

Wohnort: Finsterwalde

Beruf: Bürokraft

PHPKIT Version: PHPKIT 1.6.8 by PYK

Danksagungen: 279 / 416

  • Nachricht senden

9

Donnerstag, 16. Januar 2014, 20:00

Schau mal in der Datei nach, wo das mit den Kommentaren oder so ist und pass diese Zeile für dich an wo das mit den 0,1,1,1 steht. musst ja nur $commenttext ändern und $commentinfo['commenttext'] gegen das, was dort in der datei steht. dann gehen die Smilies auch wieder.

PHP-Quelltext

1
2
pkLoadClass($BBCODE,'bbcode');          
$commenttext $BBCODE->parse($commentinfo['commenttext'],0,1,1,1);
Mach auch du mit bei AC-Town Virtual Town ~~AC-Town Virtual Town~~

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

mono (18. Januar 2014, 10:43)

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

10

Donnerstag, 16. Januar 2014, 20:34

Das bekomme ich nicht hin... :pardon: wo muss ich was machen? :rolleyes:
LG, mono

reddevil82

PHPKIT Oldie

  • »reddevil82« ist männlich
  • »reddevil82« ist ein verifizierter Benutzer

Beiträge: 3 204

Wohnort: Spiesen-Elversberg

Beruf: Einzelhandelskaufmann

PHPKIT Version: Kein PHPKIT

Danksagungen: 1028 / 371

  • Nachricht senden

11

Freitag, 17. Januar 2014, 20:02

Mach mal bitte einen Screen wie es bei dir aussieht wenn du Smilies einsetzt.
Auch mal den Bedanken Button nutzen tut nicht weh und der Ersteller freut sich umso mehr.

Zitat von »Friedrich Nietzsche«

Der, welcher etwas Großes schenkt, findet keine Dankbarkeit, denn der Beschenkte hat schon durch das Annehmen zu viel Last.

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

12

Samstag, 18. Januar 2014, 10:44

So schaut das dann aus:

Das "Doppelpunkt, Unterstrich, Doppelpunkt, Klammer" müsste als Smilie dargestellt werden: :)
»mono« hat folgendes Bild angehängt:
  • Bildschirmfoto 2014-01-18 um 10.41.04.png
LG, mono

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

13

Samstag, 18. Januar 2014, 11:27

Haste den Bug gefixt ? " Smilie Fix bei Nutzung von () "

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

14

Samstag, 18. Januar 2014, 23:10

Ha - funzt! Ihr seid die besten! Merci!
LG, mono

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

15

Dienstag, 21. Januar 2014, 21:32

Irgendwas stimmt da noch nicht ganz. Einige Smilies werden grafisch dargestellt und andere nicht:




das 2thumbsup müsste auch als Smilie dargestellt werden.
LG, mono

knuddi

Verifiziertes Mitglied

  • »knuddi« ist männlich
  • »knuddi« ist ein verifizierter Benutzer

Beiträge: 942

Wohnort: Finsterwalde

Beruf: Bürokraft

PHPKIT Version: PHPKIT 1.6.8 by PYK

Danksagungen: 279 / 416

  • Nachricht senden

16

Dienstag, 21. Januar 2014, 21:45

Schau mal im ACP bei den Smilies ob da Leerzeichen davor bzw. dahinter sind ;)
gerade diese verursachen dieses Problem. Am besten mal die Leerzeichen rausnehmen beim editieren.
Mach auch du mit bei AC-Town Virtual Town ~~AC-Town Virtual Town~~

Es hat sich bereits 1 registrierter Benutzer bedankt.

Benutzer, die sich für diesen Beitrag bedankt haben:

mono (21. Januar 2014, 23:18)

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

17

Dienstag, 21. Januar 2014, 23:18

Ja, Tatsache - es war ein Leerzeichen mit bei. Das habe ich weggemacht und jetzt sieht es so aus:



:D
LG, mono

Sascha

PHPKIT Urgestein

  • »Sascha« ist männlich
  • »Sascha« ist ein verifizierter Benutzer

Beiträge: 2 310

Wohnort: Dietzenbach

Beruf: Ruhestand

PHPKIT Version: Kein PHPKIT

Danksagungen: 722 / 233

  • Nachricht senden

18

Dienstag, 21. Januar 2014, 23:55

smiels links bbcode ect düfen keine leerzeich und sonder zeichen habe bzw umlaute äöüß usw.

Zitat von »Robert Lembke«

Mitleid bekommt man geschenkt, Neid muss man sich verdienen.

Wer seine HP im Profil nicht hinterlegt, erhält keinen Support.
Danke sagen tut nicht weh und der klick auf den Button Bedanken kostet auch kein Geld.
Der Weg ist das Ziel, aber manchmal ist das ASCE im Weg!

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

19

Mittwoch, 22. Januar 2014, 00:03

hm, sonst ging der Code 2thumbsupimmer problemlos. Der Smilie mit dem Hütchen hat den Zeichencode :chen - also mit Sonderzeichen und der wird problemlos dargestellt.
LG, mono

mono

Verifiziertes Mitglied

  • »mono« ist weiblich
  • »mono« ist ein verifizierter Benutzer

Beiträge: 293

Wohnort: NRW

Beruf: Studentin

PHPKIT Version: PHPKIT 1.6.6

Danksagungen: 22 / 145

  • Nachricht senden

20

Mittwoch, 22. Januar 2014, 08:06

Juhu - der Smilie wird wieder angezeigt. Hatte ihn gestern schon gelöscht und wieder hochgeladen ohne das es war geändert hat. Hab ihn jetzt noch umbenannt und dann neu hochgeladen und siehe da - der Zeichencode wird nun wieder als Smilie angezeigt. Danke für eure Hilfe!
LG, mono

Social Bookmarks